Troubleshooting

Basic Installation

Warning: TensorFlow v0.12.0 and 0.12.1 broke compatibility with Edward. Use at most TensorFlow v0.11.0 for now.

Edward depends on

  • NumPy (>=1.7)
  • Six (>=1.1.0)
  • TensorFlow (>=0.11.0rc0, !=0.12.0rc0, !=0.12.0rc1, !=0.12.0, !=0.12.1)

We recommend using pip to install numpy, six, and tensorflow as

pip install numpy six tensorflow

To use Edward with GPUs, install tensorflow-gpu instead of tensorflow as

pip install tensorflow-gpu

Full Installation

Edward has optional features that depend on external packages.

  • Neural networks are supported through three libraries: Keras (>=1.0)
    pip install keras

    TensorFlow Slim (native in TensorFlow), and PrettyTensor (>=0.5.3)

    pip install prettytensor
  • The Stan modeling language is supported through PyStan (>=2.0.1.3).
    pip install pystan
  • The PyMC3 modeling language is supported through PyMC3 (>=3.0).
    pip install pymc3